Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

amzijni.dll dependent libraries

Hi Dennis,
Retired some years ago, now getting back into it again (been a while since we chatted). Using Windows 10, have installed amzi_apls_win64_10-0-05 and eclipse neon, set directories and environment variables, according to instructions. Also added amzi jar file, and added the apls\bin folder, within eclipse. In trying to run the Hello.java file, got the following error:

Unable to load (lib)amzijni library: C:\amzi\apls\bin\amzijni.dll: Can't find dependent libraries

What to do? (Had actually begun revamping my old project, and got this error -- in netbeans, as well, and isolated it to constructing a new LogicServer, so tried the Hello project. Same problem.)

Comments

  • Try setting the environment variable AMZI_DIR to point to your amzi/apls directory.
  • Had already set the variable to that directory (C:\amzi\apls). Still no dice.
  • Hmmm. Reading the message more carefully, Amzi! just spits back out the OS message, the problem appears to be the libraries that amzijni.dll uses. There is a free utility, dependency walker, that does what the name says it does. amzijni.dll, should be just dependent on amzi.dll and the kernal. Which makes me wonder if you can run the command line interpreter, say. Or if amzi.dll is in a different place from amzijni.dll? This seems unlikely to me.... Anyway, take a look at dependency walker and see if you can figure out what it's unable to find. --Dennis
Sign In or Register to comment.